using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AX[BCD][EFG](\d[A-Z\d]{4}|[A-Z\d]\d[A-Z\d]{3}|[A-Z\d]{2}\d[A-Z\d]{2}|[A-Z\d]{3}\d[A-Z\d]|[A-Z\d]{4}\d)";
string input = @"AXBE1BCDE
AXBEA2CDE
AXBEAB3DE
AXBEABC4E
AXBEABCD5
AXBE1BCD5
AXBE12345
AXBEABCDE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}