using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(.*?):(|\s)(.*?);";
string input = @"div {
color: red;
background-color: red;
}
<div style='color: red; background-color: black'>
\b(.*?):(|\s)(.*?);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}