$re = '/^(?!(\=|\<))(.*?):(.*?);/m';
$str = 'div {
color: red;
background-color: red;
}
<div style=\'color: red; background-color: black\'>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);