#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[\s\S]*(?:location="([^"]*)")[\s\S]*"
Local $sString = "<xxxx location="file path/level1/level1" xxxx some="xxx">" & @CRLF & _
"<xxxx location="file path/level1/level2" xxxx some="xxx">" & @CRLF & _
"<xxxx location="file path/level1/level3" xxxx some="xxx">"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)