re = /\s*([^!.?]*?NSF[^!.?]*?[?])/
str = 'This is a string. Is this a question? This isn\'t a question about NSF. Is this one about NSF? This one is a question about NSF but is it longer?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end