$re = '/\"(?<last_name>[^ \"]+)\s|\"(?<first_name>[^ \"]+)/m';
$str = '""Liam John" "Grayson Roy" "Olivia"" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);