# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\*].+?SemprePresente1=(\d{2}\/\d{4}).+?SemprePresente2=(\d{6})(?:(?!Opcional=)[^\*])+(Opcional=(\d+,\d+))?[^\*]+"
test_str = ("********************\n"
"SemprePresente1=09/2019\n"
"SemprePresente2=987456\n"
"Um monte de coisas \n"
"Que não preciso\n"
"Opcional=698,00\n"
"Mais coisas que não preciso\n"
"********************\n"
"SemprePresente1=06/2019\n"
"SemprePresente2=123658\n"
"Um monte de coisas \n"
"Que não preciso\n"
"********************\n"
"SemprePresente1=09/2019\n"
"SemprePresente2=987699\n"
"Um monte de coisas\n"
"Opcional=9999,00\n"
"Mais coisas que não preciso")
subst = "\\1;\\2;\\4\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.