Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((?:"pin"\s*:\s*"|"secretCode"\s*:\s*"|<pin>|<secretCode>))[0-9]{4}(?:("|<\/pin>|<\/secretCode>))
/
gm
Input 1
1
New
{ "pin":"0000", "secretCode":"0000" } <xml> <pin>0000</pin> <secretCode>0000</secretCode> </xml>