re = /^>.*$/m
str = 'test >11 years old
>twin brother dies
>parents dont let me go to his funeral or tell me where it is
>tells me it would be innapropriate to be there as it could confuse people
i dided'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end