package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)`)
var str = `This is a man's world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}