$re = '/^[a-zA-Z0-9_]+(?: *[+\/*-] *[a-zA-Z0-9_]+)*$/m';
$str = 'as + dfg - r_wer * rwer / r3r
r43 43rt43t 5rt
erte * rewtewt rrte';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);