$re = '/{((?:[^{}]++|(?R))*)}/m';
$str = '#242424##{FFFFF}{2{GGFFFGF}{BBBBB}}{GGGG}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);