const regex = /^(?:\d+\.\d+\,){123}(\d+\.\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d+\\.\\d+\\,){123}(\\d+\\.\\d+)', 'g')
const str = `1516924800000,0.00063951,0.00063997,0.00063339,0.00063388,1145.00000000,1517011199999,0.72784872,53,453.00000000,0.28847478,0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}