$re = '/(?<=a )[ac]+|(?<=b )[bd]+/m';
$str = 'a caca
b bdbd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);