# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/$(?![\w\W])/text_to_replace/gm;t' <<< "abc
def
ghi"