#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)$(?![\w\W])"
Local $sString = "abc" & @CRLF & _
"def" & @CRLF & _
"ghi"
Local $sSubst = "text_to_replace"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)