using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"$(?![\w\W])";
string substitution = @"text_to_replace";
string input = @"abc
def
ghi";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}