re = /\/portal\/(?!static\/).*/m
str = '/portal/static123
/portal/test
/portal/test/123
/portal/static/doesntmatch
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end