import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\/\\*A-Z0-9_\\s]*(?=\\{)\\{RSTART_(?=(([A-Z0-9]{6}[0-9]))).+(?=(RSTART_(?=(([A-Z0-9]{6}[0-9]))))).+$";
final String string = " {RSTART_IDT1S03, RSTART_IDT1S03},";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}