use strict;
my $str = '4/1,6/5,6/1,1,2,3,4,5
5,4,3,2,1,1/3,4/4,2/5
2,5,3,2,1,1/3,4/4,2/5asdf
1asdf
4/1
2/3,1,2,3
,2/3,1,2,3
2/3,1,2,3,4,5
,2/3,1,2,3,4,5
5,2/3,1,2,3
4/1,2/3,1,2,3,4,5
1/4,2/3,1,2,3,4,5';
my $regex = qr/^(([1-4][/][1-4])*)(([,][1-4][/][1-4])*)(([1-4])*)(([,][1-4])*)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}