// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(([1-4][/][1-4])*)(([,][1-4][/][1-4])*)(([1-4])*)(([,][1-4])*)$").unwrap();
let string = "4/1,6/5,6/1,1,2,3,4,5
5,4,3,2,1,1/3,4/4,2/5
2,5,3,2,1,1/3,4/4,2/5asdf
1asdf
4/1
2/3,1,2,3
,2/3,1,2,3
2/3,1,2,3,4,5
,2/3,1,2,3,4,5
5,2/3,1,2,3
4/1,2/3,1,2,3,4,5
1/4,2/3,1,2,3,4,5";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}