package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*/vp/([^/?]*?)\.[^/?.]*(?:\?.*)?$`)
var str = `someurl.com/vp/125514_45147_55144.jpg?_nc25244`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}