use strict;
my $str = 'someurl.com/vp/125514_45147_55144.jpg?_nc25244';
my $regex = qr~.*/vp/([^/?]*?)\.[^/?.]*(?:\?.*)?$~mp;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";