// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*/vp/([^/?]*?)\.[^/?.]*(?:\?.*)?$").unwrap();
let string = "someurl.com/vp/125514_45147_55144.jpg?_nc25244";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}