import Foundation
let pattern = #".*/vp/([^/?]*?)\.[^/?.]*(?:\?.*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"someurl.com/vp/125514_45147_55144.jpg?_nc25244"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)