import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^";
        final String string = "\"Cliente1\\\\Rem\\\\COB0111111.REM.txt\"\n"
	 + "\"Cliente1\\\\Rem\\\\23123123.REM.txt\" \n"
	 + "\"Cliente1\\\\OK\\\\COB02222222.REM.txt\" \n"
	 + "\"Cliente1\\\\Ret\\\\COB0613062019.REM.txt\"\n"
	 + "\"COB0613062019.REM.txt\" \n"
	 + "\"Cliente2\\\\COB0613062019.REM.txt\"\n"
	 + "\"Cliente2\\\\Rem\\\\COB0633333.REM.txt\"\n"
	 + "\"Cliente2\\\\Rem\\\\pasta2\\\\COB02123123.REM.txt\"\n"
	 + "\"Cliente2\\\\Bla\\\\Rem\\\\COB0613062019.REM.txt\"\n"
	 + "\"Cliente1\\\\COB0613062019.REM.txt\"\n"
	 + "\"Rem\\\\COB0613062019.REM.txt\" \n"
	 + "\"Rem\"\n"
	 + "\"Cliente3\"";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}