// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^").unwrap();
let string = "\"Cliente1\\\\Rem\\\\COB0111111.REM.txt\"
\"Cliente1\\\\Rem\\\\23123123.REM.txt\"
\"Cliente1\\\\OK\\\\COB02222222.REM.txt\"
\"Cliente1\\\\Ret\\\\COB0613062019.REM.txt\"
\"COB0613062019.REM.txt\"
\"Cliente2\\\\COB0613062019.REM.txt\"
\"Cliente2\\\\Rem\\\\COB0633333.REM.txt\"
\"Cliente2\\\\Rem\\\\pasta2\\\\COB02123123.REM.txt\"
\"Cliente2\\\\Bla\\\\Rem\\\\COB0613062019.REM.txt\"
\"Cliente1\\\\COB0613062019.REM.txt\"
\"Rem\\\\COB0613062019.REM.txt\"
\"Rem\"
\"Cliente3\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}