#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\#)(?<!\#\s)(?<!\w)parameter=[0-9]+"
Local $sString = "# default parameter" & @CRLF & _
"parameter=3" & @CRLF & _
"someparameter=3" & @CRLF & _
"a parameter=3" & @CRLF & _
"###parameter=3" & @CRLF & _
"# ## parameter=3" & @CRLF & _
"## # parameter=3" & @CRLF & _
"# parameter=3" & @CRLF & _
"# parameter=3" & @CRLF & _
"something something # parameter=3" & @CRLF & _
" parameter=3" & @CRLF & _
"#something parameter=3" & @CRLF & _
"# something parameter=3" & @CRLF & _
"parameter=#3" & @CRLF & _
"parameter="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")