const regex = /(?<!\#)(?<!\#\s)(?<!\w)parameter=[0-9]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\#)(?<!\\#\\s)(?<!\\w)parameter=[0-9]+', 'gm')
const str = `# default parameter
parameter=3
someparameter=3
a parameter=3
###parameter=3
# ## parameter=3
## # parameter=3
# parameter=3
# parameter=3
something something # parameter=3
parameter=3
#something parameter=3
# something parameter=3
parameter=#3
parameter=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}