import re
regex = re.compile(r"(?:\S+)\s+(?:\S+)\s+(?:\S+)\s+(.+)", flags=re.MULTILINE)
test_str = ("aaax bbb ccc ddd\n"
"mmmxxx nnn ooo ppp sjkhdkjsh skdjhsksdkskjdh ksjh sdkjsdh ksjdh\n"
"fffxx ggg hhh iii")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")