#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(([^0-9\r\n]*\d){3}))(?!(.*-){2})(?!(.*\/){2}).*$"
Local $sString = "02ABU-D9435" & @CRLF & _
"13DFC" & @CRLF & _
"1123451" & @CRLF & _
"03323456782" & @CRLF & _
"ADS7124536768" & @CRLF & _
"03SDFA9433/0" & @CRLF & _
"03SDFA9433/" & @CRLF & _
"03SDFA9433/1" & @CRLF & _
"A41B03423523" & @CRLF & _
"O4AGFC4430" & @CRLF & _
"01/01/2018" & @CRLF & _
"AA-AA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")