package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)policy\s+number\s+([A-Z]{4}\d+)\b`)
var str = ` Policy Number ABCD000012345 other text follows in same line....`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}