re = /(?i)policy\s+number\s+([A-Z]{4}\d+)\b/m
str = ' Policy Number ABCD000012345 other text follows in same line....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end