# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(NT\$|SAR)\s(\d{2,5})|\d{1,4}([.,]\d{3})*([\s.,]\d{2,3}|[^\W]\d+(\d{1,4})*\s(kr|zł|Pesos|Kč|Ft|บาท|SAR|₪))"
test_str = ("Everything Matches\n\n"
"1.4\">$19.99\n"
"1.4\">R$20.00\n"
"1.4\">20.00€\n"
"1.4\">€25,99\n"
"1.4\">£15.99\n"
"1.4\">123 kr\n"
"1.4\">1234 Ft\n"
"1.4\">999 Pesos\n\n"
"but my output will look like:\n\n"
"$19.99\n"
"R$20.00\n"
"20.00€\n"
"€25,99\n"
"£15.99\n"
"123 kr\n"
"1234 Ft\n"
"999 Pesos")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.