// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(NT\$|SAR)\s(\d{2,5})|\d{1,4}([.,]\d{3})*([\s.,]\d{2,3}|[^\W]\d+(\d{1,4})*\s(kr|zł|Pesos|Kč|Ft|บาท|SAR|₪))").unwrap();
let string = "Everything Matches
1.4\">$19.99
1.4\">R$20.00
1.4\">20.00€
1.4\">€25,99
1.4\">£15.99
1.4\">123 kr
1.4\">1234 Ft
1.4\">999 Pesos
but my output will look like:
$19.99
R$20.00
20.00€
€25,99
£15.99
123 kr
1234 Ft
999 Pesos";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}