re = /~~([\s\S]*?)~~(?!~)|~([^~]*)~/m
str = 'This is a demo paragraph with a wrapped string ~here~, with another string ~~here~~.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end