$re = '/(?<!\w)HIPAA(?!\w)|(?<!\w)ERP\(2.0\)(?!\w)/m';
$str = 'HIPAA and ERP
HIPAA and ERP(2.0)
HIPAASTOL and ERP(2.0)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);