Group pan_log_receive_time(?P<pan_log_receive_time>\w{3}\s*\d+\s*\d+:\d+:\d+) \w{3}any word character, repeated exactly 3 times
\s*any whitespace character, repeated any number of times
\d+a digit, repeated at least once
\s*any whitespace character, repeated any number of times
\d+a digit, repeated at least once
:the literal : (5810 / 728 / 3A16)
\d+a digit, repeated at least once
:the literal : (5810 / 728 / 3A16)
\d+a digit, repeated at least once
\s+any whitespace character, repeated at least once
Non-Capturing Group(?:[^,]*,){3} {3}repeats the group contents below exactly 3 times:
Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_log_type(?P<pan_log_type>THREAT) THREATthe literal text THREAT (case sensitive) ,the literal , (4410 / 548 / 2C16)
Group pan_log_subtype(?P<pan_log_subtype>[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Non-Capturing Group(?:[^,]*,){2} {2}repeats the group contents below exactly 2 times:
Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_log_src(?P<pan_log_src>[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_log_dst(?P<pan_log_dst>[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Non-Capturing Group(?:[^,]*,){2} {2}repeats the group contents below exactly 2 times:
Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_threat_policy(?P<pan_threat_policy>[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_threat_srcuser(?P<pan_threat_srcuser>[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Non-Capturing Group(?:[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_threat_app(?P<pan_threat_app>[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_threat_vsys(?P<pan_threat_vsys>[^,]*) Negated Character Class[^,]* *matches any number of characters outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
Group pan_threat_srczone(?P<pan_threat_srczone>[^,]*) Negated Character Class[^,]* ,the literal , (4410 / 548 / 2C16)
Group pan_threat_dstzone(?P<pan_threat_dstzone>[^,]*) ,the literal , (4410 / 548 / 2C16)
Group pan_threat_inbound_if(?P<pan_threat_inbound_if>[^,]*) ,the literal , (4410 / 548 / 2C16)
Group pan_threat_outbound_if(?P<pan_threat_outbound_if>[^,]*) ,the literal , (4410 / 548 / 2C16)
Non-Capturing Group(?:[^,]*,){4} Group pan_log_sport(?P<pan_log_sport>[^,]*) ,the literal , (4410 / 548 / 2C16)
Group pan_log_dstport(?P<pan_log_dstport>[^,]*) ,the literal , (4410 / 548 / 2C16)
Non-Capturing Group(?:[^,]*,){3} Group proto(?P<proto>[^,]*) ,the literal , (4410 / 548 / 2C16)
Group action(?P<action>[^,]*) \(the literal ( (4010 / 508 / 2816)
Group threat_id(?P<threat_id>\d+) \)the literal ) (4110 / 518 / 2916)
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string