$re = '/^[+-]?((\d+(\.\d+)?)|(\.\d+))$/m';
$str = '0.00000
0.00
-200
+200
200
200.2
-200.2
+200.2
.000
.1
.2
3.
.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);