#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x){%\ for.*?%}" & @CRLF & _
"(?s:.+?)" & @CRLF & _
"{%\ endfor.*?%}"
Local $sString = "{% for user in users %}" & @CRLF & _
" Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}" & @CRLF & _
"ssssssssssssssssssssss {{ user.name }}" & @CRLF & _
"sdsddddddddddddddddddddddddddddd" & @CRLF & _
"{% endfor %}" & @CRLF & _
"" & @CRLF & _
"{% for dog in dogs %}" & @CRLF & _
" Your dog is {{ dog.age }} and likes {{ dog.food }}." & @CRLF & _
"{% endfor %}" & @CRLF & _
"wwww" & @CRLF & _
"{{ user.name }}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")