$re = '/^([A-Za-z \',-]+\.?)$/m';
$str = 'Baxter
Doe de Sour Jr.
Smith-Brown
Mathias d\'Arras
d\'Arras
King, Jr.
Cotton III
Baxter2
user@gmail
#michael
tina.fay';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);