# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\"?([^\""]*)\"? \"?([^\""]*)\"? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})//g;t' <<< "\"Mattias Asplund\" 46 35000.00 070-6186120"