import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"?([^\\\"\"]*)\\\"? \\\"?([^\\\"\"]*)\\\"? (\\d{2}) (\\d{5}).(\\d{2}) (\\d{3}-\\d{7})";
final String string = "\"Mattias Asplund\" 46 35000.00 070-6186120";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}