#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\: (.*), (.*); Area"
Local $sString = "Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567" & @CRLF & _
"Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333"
Local $sSubst = "/: \2 \1; Area/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)