package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\: (.*), (.*); Area`)
var str = `Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567
Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333`
var substitution = "/: \2 \1; Area/"
fmt.Println(re.ReplaceAllString(str, substitution))
}