import Foundation
let pattern = #"\: (.*), (.*); Area"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Name: Feld, Ray; Areas: PC, UNIX; Phone: 123-4567
Name: Joy, Susan s.; Areas: Graphics; Phone: 999-3333
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/: \2 \1; Area/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)