using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""|(very)";
string input = @"Fred Smith, very loudly said yesterday at a press conference that very fresh peas will ""very, very defintely not"" be served at the upcoming county fair";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}