// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""[^"]*"|(very)"#).unwrap();
let string = "Fred Smith, very loudly said yesterday at a press conference that very fresh peas will \"very, very defintely not\" be served at the upcoming county fair";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}