package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/www\.reddit\.com\/r\/.+`)
var str = `https://www.reddit.com/r/userscripts/comments/u3avus/greasemonkey_regex_for_matching_only/
https://www.reddit.com/r/ForzaHorizon/new/
https://www.reddit.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}