#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z0-9]*?)([-_]?)([A-Z0-9]+\.SV)$"
Local $sString = "TRND-0LL2134.SV" & @CRLF & _
"TRN_RTXDFT.SV" & @CRLF & _
"TRND_ZRSFTFF.SV" & @CRLF & _
"DR3345.SV"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")